Back to overview
Degraded

Some sites failing to deploy

May 22, 2026 at 7:27am UTC
Affected services
Builders

Resolved
May 22, 2026 at 8:40am UTC

A fix has been created and rolled out. The issue with deploying some sites has been resolved.

Updated
May 22, 2026 at 8:21am UTC

We have identified the root cause and are fixing the affected sites.

Created
May 22, 2026 at 7:27am UTC

We are investigating an issue where some sites are failing to deploy.