Back to overview
Degraded

Dashboard login links are not properly delivered

Apr 1, 2026 at 1:05pm UTC
Affected services
Dashboard

Resolved
Apr 1, 2026 at 3:56pm UTC

The issues have been resolved. Thank you for your patience.

Created
Apr 1, 2026 at 1:05pm UTC

We are having issues with our transactional email service, resulting in login links not being delivered properly. We are investigating the issue together with our email provider.

Users with active login sessions are not affected.

Please contact support for help with managing your site during this time.