Issues with some certificates and deployments
Resolved
Feb 24, 2026 at 11:11pm UTC
All issues have been fixed and everything is working normally again.
Thank you so much for your patience and understanding!
Affected services
Updated
Feb 24, 2026 at 8:22pm UTC
We have identified the underlying issue and are rolling out the fix. Expect some degraded performance while we get everything in order.
Affected services
Updated
Feb 24, 2026 at 7:49pm UTC
We are now rerouting traffic, but have reports of some still degraded performance.
Affected services
Updated
Feb 24, 2026 at 6:22pm UTC
Site deployments are working as expected again, but we are still working on the underlying issue.
Affected services
Created
Feb 24, 2026 at 5:02pm UTC
We are experiencing some issues with certificate management and site deployments, and are investigating.
Affected services